Sensor cleaning

I’ve had spots on the sensor of my Pentax K20D for some time. In fact I think they were there for some years before I finally noticed.

I splashed out on some stuff – Eclipse Optic Cleaning  fluid and Sensor Swab sensor cleaning swabs. VERY expensive for what you appear to get, I think you’re mostly paying for some reassurance that the swabs are made in an aerospace-grade clean room and guaranteed to be free from anything nasty that might scratch your sensor. Let’s face it, if you damage your sensor then that’s your camera gone.

Here’s a shot of a plain background that shows the problem.

_IGP7955
Dirty marks on my Pentax sensor

You can clearly see the marks.

Cleaning on the Pentax starts by choosing the sensor cleaning menu option – Set-up -> Sensor Cleaning. You choose Mirror Up, press OK and the mirror flips up and stays up until you turn the power off.

Next you follow the Sensor Swab instructions. A drop of fluid on a new swab and swipe twice across the sensor, once with each side of the swab.

However – here’s where the experience comes in. While you’ve still got the mirror up, look very closely at the sensor surface. If you look carefully you may be able to see the dirt spots. I found they either didn’t go away first time and needed some mild “scrubbing” with the swab, or even that I replaced one dirt mark with another. I used three swabs in total, needing to scrub with one of them. I could see the marks with my naked eye and I could see when I had scrubbed enough. Scrubbing is perhaps an exaggeration – rubbing might be a better word, back and forth over the mark until it went.

Between each pass I had to take a shot (unfocussed, to make sure anything I saw was a sensor artifact) of a plain white background and import into lightroom to see what I could see. After three swabs all the marks had gone.

You need to be very careful before you start that you don’t have anything abrasive on the sensor, like a grain of sand. You really wouldn’t want to swab that across. Also be careful not to put too much fluid on the swab or it might leave a wet streak.

PS: I also got my Lee filters out to clean them after a trip to the seaside. Warm soapy water and a good rinse, perfect. I’d be careful in a hard water area though.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s